Yamp52 is alive and kicking…

Yamp52 is alive and kicking…

Przy okazji wykorzystania tego frameworku, postanowiłem go nieco odświeżyć. Yamp52 wykorzystuje teraz ORM Doctrin2 oraz bibliotekę Smarty w wersji 3.
Ułatwiłem też wstrzykiwanie zależności. Od teraz odbywa się ono poprzez refleksję, a nie jak do tej pory przez magiczne wywołanie metod __set. Co za tym idzie, serwisy nie muszą już implementować interfejsu Injectable.

Nowe biblioteki narzuciły także minimalną wersję PHP na 5.
Zapraszam do wykorzystywania kodu, który znajduje się tutaj

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.